Bekomme keine Verbindung zum TXT hin :-(

Alles rund um TX(T) und RoboPro, mit ft-Hard- und Software
Computing using original ft hard- and software
Forumsregeln
Bitte beachte die Forumsregeln!
Antworten
metawops
Beiträge: 9
Registriert: 13 Nov 2017, 18:29
Wohnort: Bonn
Kontaktdaten:

Bekomme keine Verbindung zum TXT hin :-(

Beitrag von metawops » 27 Jun 2021, 15:13

So, liebe Community, nach eine laaangen Pause des Beschäftigens mit fischertechnik habe ich jetzt mal wieder meinen TXT Controller Baustein aus dem Discovery Set herausgekramt. Er ist noch im Fahrroboter mit der Kamera verbaut.
Natürlich wollte ich erstmal nach aktuellen Versionen von ROBOPro und der Firmware schauen. Das Aktualisieren der ROBOPro Software auf meinem recht alten, kleinen, langsamen acer Notebook mit Windows 10 ist mir gelungen, es läuft nun die wohl neueste Version 4.6.6.

Allerdings bekomme ich keinerlei Verbindung mit dem TXT Baustein hin. Weder über USB-Kabel, noch über Bluetooth, noch über WLAN.

Der Controller wird über das fischertechnik 9V Netzteil mit Strom versorgt und bootet problemlos seine aktuelle Firmware Version 4.2.4.0.
Sobald ich ihn über ein USB-Kabel mit dem Notebook verbinden macht Windows das übliche "neue Hardware gefunden" Geräusch und installiert etwas. Am Ende dieses Prozesses gibt es ein neues Gerät, was mit einem COM Port (in meinem Fall COM3 oder COM4, jenachdem, welchen USB-Port ich am Notebook benutzt habe) verbunden ist. Zu sehen im Device Manager unter "Ports (COM & LPT)" als "USB Serial Device (COMx)" (mit x=3 oder 4).

In ROBOPro klicke ich dann auf den COM/USB Button und kann in der linken Spalte nur "USB/WLAN/Bluetooth" oder "Simulation" auswählen. COM1 bis COM4 sind ausgegraut. In der rechten Spalte ist natürlich "ROBOTICS TXT Controller" ausgewählt. Im folgenden Dialog habe ich natürlich zuerst "USB - Standard" ausgewählt.
Nach Klick auf den "Test" Button dauert es ca. 5 Sekunden, dann erscheint zunächst ein Dialog mit dem Titel "Öffnen der USB Schnittstelle" und dem Inhalt "Error". Nach Klick auf den OK Button erscheint ein zweiter Dialog mit Titel "Fehler während der Verbindung zum Interface" und Inhalt "ROBOPro konnte keine Verbindung zum Interface herstellen. Bitte die Einstellungen mit dem COM/USB Knopf."

Ich konnte den TXT erfolgreich per Bluetooth mit Windows koppeln. Aber es erscheinen genau die selben Fehlerdialoge wie im Falle von USB.

Wenn ich den TXT in den WLAN Access Point Modus versetzte und mein Notebook per WLAN mit ihm verbinden (das gelingt) und dann im COM/USB Dialog (Teil 2) "WLAN - Standard" wähle, passiert ein bisschen was anderes: Es erscheint ein Firmwareaktualisierungsdialog, der sagt, dass die Firmware 4.2.4.0 ist und dass sie auf 4.6.6.0 aktualisiert werden müsse. Nach Klick auf OK allerdings kommt unmittelbar(!) ein Fehlerdialog mit dem Titel "Firmwareaktualisierung" und dem Inhalt "Fehler während Firmware-Update Phase 1. Ergebnis Code 1. Fehlermeldung:", es fehlt dann leider die tatsächliche Fehlermeldung hinter dem Doppelpunkt.

Nun bin ich ratlos, was ich noch probieren könnte. Abgesteckt vom USB-Port habe ich ihn schon mehrfach, beide USB Ports des Notebook schon mehrfach probiert. Auch den installierten COM3/COM4 Port entfernt und neu installieren lassen ... half bisher alles nichts. :-(

Habt ihr eine Idee? Vielen herzlichen Dank schonmal im Voraus!

Benutzeravatar
MasterOfGizmo
Beiträge: 2335
Registriert: 30 Nov 2014, 07:44

Re: Bekomme keine Verbindung zum TXT hin :-(

Beitrag von MasterOfGizmo » 27 Jun 2021, 19:42

Der TXT macht keinen COM-Port auf, sondern eine Netzwerkverbindung. Auch bei Anschluss per USB. Entsprechend kann man in RoboPro auch keinen COM-Port auswählen.

Per USB sollte RoboPro ihn unter der IP-Adresse 192.168.7.2 erreichen.
Für fischertechnik: Arduino ftDuino http://ftduino.de, Raspberry-Pi ft-HAT http://tx-pi.de/hat

Benutzeravatar
Bjoern
Beiträge: 393
Registriert: 04 Jan 2018, 12:34

Re: Bekomme keine Verbindung zum TXT hin :-(

Beitrag von Bjoern » 27 Jun 2021, 20:27

Hallo metawops,

du hast eine sehr alte Firmware drauf. Das mit dem WLAN ist schon eine gute Idee. Ansonsten müsste es eigentlich auch per USB und Netzwerkadresse gehen.
Ich meine mich zu erinnern das du von der ganz alten version nicht auf die 4.6.6 direkt hochrüsten kannst.
Schau mal hier: https://github.com/fischertechnik/FT-TXT/tags

Versuche es mal erst mit der kleinsten dort vorhandenen Version. Solange RoboPro auf dem PC und die Firmware des TXT nicht die gleiche Version haben, hast du immer Probleme. Allerdings versucht RoboPro auch immer das Firmware Update wenn es neuer ist.

Versuche mal den Weg über eine ältere Version.

Und die neueste Version ist eben nur noch nicht "offiziell" released. Deswegen nur bei github.

Grüße
Björn

metawops
Beiträge: 9
Registriert: 13 Nov 2017, 18:29
Wohnort: Bonn
Kontaktdaten:

Re: Bekomme keine Verbindung zum TXT hin :-(

Beitrag von metawops » 28 Jun 2021, 11:55

Ich hatte beim Suchen hier in einem anderen Thread gelesen, dass jemand in Windows — da ging es aber um Windows 7! — erst den DHCP Dienst aktivieren musste, ehe bei ihm diese Verbindungen klappten.
Unter Windows 10 habe ich bisher nicht gefunden, wo man den DHCP Dienst aktivieren kann … Vielleicht könnte das ja das Problem lösen?!

Karl
Beiträge: 1698
Registriert: 24 Sep 2016, 17:28

Re: Bekomme keine Verbindung zum TXT hin :-(

Beitrag von Karl » 28 Jun 2021, 12:15

Hallo,
vielleicht hilft folgender Link ?
https://www.wintotal.de/tipp/dhcp-aktivieren/
und scrollen.
Grüße von
Karl

metawops
Beiträge: 9
Registriert: 13 Nov 2017, 18:29
Wohnort: Bonn
Kontaktdaten:

Re: Bekomme keine Verbindung zum TXT hin :-(

Beitrag von metawops » 28 Jun 2021, 12:40

Bjoern hat geschrieben:
27 Jun 2021, 20:27
Hallo metawops,

du hast eine sehr alte Firmware drauf. Das mit dem WLAN ist schon eine gute Idee. Ansonsten müsste es eigentlich auch per USB und Netzwerkadresse gehen.
Ich meine mich zu erinnern das du von der ganz alten version nicht auf die 4.6.6 direkt hochrüsten kannst.
Schau mal hier: https://github.com/fischertechnik/FT-TXT/tags

Versuche es mal erst mit der kleinsten dort vorhandenen Version. Solange RoboPro auf dem PC und die Firmware des TXT nicht die gleiche Version haben, hast du immer Probleme. Allerdings versucht RoboPro auch immer das Firmware Update wenn es neuer ist.

Versuche mal den Weg über eine ältere Version.

Und die neueste Version ist eben nur noch nicht "offiziell" released. Deswegen nur bei github.

Grüße
Björn
Danke für den Hinweis, Björn.
Habe gerade mal geschaut. Die direkt nächste Firmware (und ROBOPro Version), die es auf github gibt, wäre die 4.4.3. Leider hängt an ihr als asset aber die ROBOPro Version 424 ("Setup424.msi"). Habe es zunächst damit versucht. Immerhin konnte ich so (bei WLAN Verbindung zum TXT) erfolgreich den Info Button drücken und sah den Dialog mit all den Statusangaben zu den Inputs, Outputs etc. Aber leider poppte davor kein Dialog zur Firmwareaktualisierung auf (kein Wunder, es war ja auch tatsächlich nur wie im Dateinamen angegeben die Version 4.2.4, die ja schon auf meinem TXT drauf ist).

Die nächste verfügbare Version auf github ist die 444. Auch diese habe ich heruntergeladen und ausprobiert. Hier taucht aber leider der selbe Fehler wie ursprünglich gemeldet auf. Ein Firmwareupdate ist also hiermit nicht möglich. Ich vermute, dass dann auch die (aktuell auf github fehlende) Version 4.4.3 ebenso nicht funktionieren würde. :-(

Ist mein TXT bricked?! :-( :-( :-(

Benutzeravatar
The Rob
Moderator
Beiträge: 944
Registriert: 03 Dez 2015, 12:54

Re: Bekomme keine Verbindung zum TXT hin :-(

Beitrag von The Rob » 28 Jun 2021, 16:31

metawops hat geschrieben:
28 Jun 2021, 12:40
Bjoern hat geschrieben:
27 Jun 2021, 20:27
Ist mein TXT bricked?! :-( :-( :-(
Allerhöchstens soweit, dass du ihn zu ft einschicken musst, und dann mit aktueller Firmware zurückbekommst.
Das dauert natürlich etwas, deswegen würde ich erstmal alles andere probieren, aber ernsthafte Sorgen musst du dir keine machen.

vleeuwen
Beiträge: 1295
Registriert: 31 Okt 2010, 22:23
Wohnort: Enschede (NL)
Kontaktdaten:

Re: Bekomme keine Verbindung zum TXT hin :-(

Beitrag von vleeuwen » 29 Jun 2021, 15:33

How to repair a damaged TXT firmware installation?
When their is no connection with the TXT possible, the installation of a firmware could be damaged.
Only a low level firmware installation could help (or sending the TXT to fischertechnik for maintannance.)
It is possible to force the installation of the firmware from SD-card with a hardware serial connection and some low level commands:
See: "Flash TXT from SD-card" at https://github.com/fischertechnik/FT-TX ... nux-FAQ.md

You will need a USB to serial converter like the ADAfruit FTDI friend.
https://www.kiwi-electronics.nl/adafrui ... lus-extras

Use google translate in case you need a German translation.
All the documentation is only available in English.

metawops
Beiträge: 9
Registriert: 13 Nov 2017, 18:29
Wohnort: Bonn
Kontaktdaten:

Re: Bekomme keine Verbindung zum TXT hin :-(

Beitrag von metawops » 29 Jun 2021, 17:29

Karl hat geschrieben:
28 Jun 2021, 12:15
Hallo,
vielleicht hilft folgender Link ?
https://www.wintotal.de/tipp/dhcp-aktivieren/
und scrollen.
Danke fürs Googeln, Karl. Das Problem hier ist, dass in diesen Artikeln immer zunächst das Netzwerkdevice, bei dem man DHCP aktivieren will, ausgewählt werden soll. Hier bei mir sehe ich dann nur meine "Wi-Fi" Verbindung (über die ich im Internet bin), eine nicht verbundene "Bluetooth Network Connection" und "Ethernet", auch mit rotem X, da nicht im Einsatz.
Aber keins dieser "Geräte" hat ja mit der Verbindung zum TXT zu tun ...
Und wie schon weiter oben geschrieben wird hier auch kein neuer Eintrag erzeugt, wenn ich den TXT via USB-Kabel verbinde. (Sondern bei den COM Ports.)

metawops
Beiträge: 9
Registriert: 13 Nov 2017, 18:29
Wohnort: Bonn
Kontaktdaten:

Re: Bekomme keine Verbindung zum TXT hin :-(

Beitrag von metawops » 29 Jun 2021, 17:30

vleeuwen hat geschrieben:
29 Jun 2021, 15:33
How to repair a damaged TXT firmware installation?
When their is no connection with the TXT possible, the installation of a firmware could be damaged.
Only a low level firmware installation could help (or sending the TXT to fischertechnik for maintannance.)
It is possible to force the installation of the firmware from SD-card with a hardware serial connection and some low level commands:
See: "Flash TXT from SD-card" at https://github.com/fischertechnik/FT-TX ... nux-FAQ.md

You will need a USB to serial converter like the ADAfruit FTDI friend.
https://www.kiwi-electronics.nl/adafrui ... lus-extras

Use google translate in case you need a German translation.
All the documentation is only available in English.
Thanks, I will keep that in mind, as a last resort, if I really don't get the firmware installed otherwise. (I have a few USB/Serial dongles at hand here.)

metawops
Beiträge: 9
Registriert: 13 Nov 2017, 18:29
Wohnort: Bonn
Kontaktdaten:

Re: Bekomme keine Verbindung zum TXT hin :-(

Beitrag von metawops » 29 Jun 2021, 17:41

MasterOfGizmo hat geschrieben:
27 Jun 2021, 19:42
Der TXT macht keinen COM-Port auf, sondern eine Netzwerkverbindung. Auch bei Anschluss per USB. Entsprechend kann man in RoboPro auch keinen COM-Port auswählen.

Per USB sollte RoboPro ihn unter der IP-Adresse 192.168.7.2 erreichen.
Also, bevor ich den mit Strom versorgten TXT an meinem WIndows 10 Notebook anschließe, habe ich im Gerätemanager unter "Ports (COM & LPT)" nur zwei Einträge: "Standard Serial over Bluetooth Link (COM5)" und "Standard Serial over Bluetooth Link (COM6)".

Nachdem ich den TXT via USB angesctlossen habe und Windows 10 sein typisches Geräusch für "neue Hardware erkannt" gemacht hat, habe ich dort einen dritten Eintrag namens "USB Serial Device (COM3)" (oder, wenn der TXT am anderen USB-Port hängt, COM4).

Karl
Beiträge: 1698
Registriert: 24 Sep 2016, 17:28

Re: Bekomme keine Verbindung zum TXT hin :-(

Beitrag von Karl » 29 Jun 2021, 18:26

Hallo,
geht das WLan oder WiFi am TXT eventuell wenn Bluetooth, beim TXT und eventuell
auch beim Rechner, deaktiviert wird oder werden ?
Grüße von
Karl

metawops
Beiträge: 9
Registriert: 13 Nov 2017, 18:29
Wohnort: Bonn
Kontaktdaten:

Re: Bekomme keine Verbindung zum TXT hin :-(

Beitrag von metawops » 30 Jun 2021, 17:33

Aktuelles (und finales ;-) ) Update zum Thema: Problem ist gelöst, ich habe jetzt die 4.4.4.0 Firmware auf meinem TXT Baustein und denke, dass jetzt auch weitere Firmwareaktualisierungen auf noch neuere Versionen kein Problem mehr sein werden.
Mein Instinkt im Umgang mit Computern seit Sinclair ZX80, C-64, TI99/4A etc. Zeiten sagte mir, dass das Problem nicht am TXT liegt, sondern etwas bei meiner Windows-Installation faul ist. Da ich mich seit vielen Jahren aber privat nur noch mit Macs auseinandersetze, habe ich den Anschluss verloren, wo/wie man bei Windows "tief in den Eingeweiden" forschen kann, um so ein Problem zu reparieren.
Daher habe ich mich kurzerhand entschlossen, in den Windows 10 Settings im Bereich Recovery den Punkt "Reset this PC" zu wählen. Dadurch wurde meine Windows Installation ordentlich aufgeräumt und in der Tat hat es sich dabei offensichtlich selbst repariert: die USB-Verbindung mit dem TXT klappt nun und die Firmware-Installation von 4.2.4.0 auf 4.4.4.0 hat auch poblemlos geklappt.
Macht mich happy, da ich gerade noch das 544624 "TXT Smart Home" Set neu erwerben konnte (ich glaube, das gibt's offiziell gar nicht mehr neu, oder?) und dieses laut Anleitung mindestens die Firmware Version 4.4.1 voraussetzt. Es kann also jetzt wieder gebastelt werden. :-)

Herzlichen Dank an alle Mitleser, Mitdenker und Ratgeber!!

Antworten