Braucht Hilfe von altem LLWin Software

Alles rund um TX(T) und RoboPro, mit ft-Hard- und Software
Computing using original ft hard- and software
Forumsregeln
Bitte beachte die Forumsregeln!
Antworten
Benutzeravatar
FeuerTischler
Beiträge: 13
Registriert: 18 Okt 2011, 04:02

Braucht Hilfe von altem LLWin Software

Beitrag von FeuerTischler » 18 Okt 2011, 04:25

hallo, i grew up "playing" FT in the 80s and in more recent years, saw the Robotics models and decided to get into it, this was in the late 1990s. Then work got a bit hectic and i had to postpone my hobby and now it's ten years later that i *finally* open that Robotics box to start tinkering !

that means i'm using the old "Intelligent Interface" and LLWin 2.1e - my old laptop has it's own problems but i managed to get a USB to RS232 cable and hooked up the new laptop to the interface via COM2 with no problem. (Setup Interface & Check Interface works fine)

the first time i hooked up the model "MR1" to the computer, everything worked okay; i could download "MR1.mdl" to the FT-model and it functioned as expected in "active mode".

but now i have a strange problem; on the 2nd try (the next day) i couldn't execute a 'download', the interface connection is okay, "Check Interface" works fine - but when i try to download "MR2.mdl" - a file is missing;
"Datei C:\LLwin210e\temp\temp.att nicht vorhanden".

what happened now and how do i fix this problem ?

thanks for any helpful suggestions.
give them NOT fish, but TEACH them HOW TO

vleeuwen
Beiträge: 1119
Registriert: 31 Okt 2010, 22:23

Re: Braucht Hilfe von altem LLWin Software

Beitrag von vleeuwen » 18 Okt 2011, 12:07

Downloading of programs for the Intelligent Interface is not supported by RoboPro (Thanks Ulrich for the correction).

Knobloch is selling a nice RoboConnectionBox. With this box it is possible to use the old interfaces (serial and parallel) over USB and work with RoboPro.
Zuletzt geändert von vleeuwen am 18 Okt 2011, 17:17, insgesamt 3-mal geändert.

UMueller
Beiträge: 220
Registriert: 31 Okt 2010, 22:58

Re: Braucht Hilfe von altem LLWin Software

Beitrag von UMueller » 18 Okt 2011, 12:55

Aber Hallo @vleeuwen,

Intelligent Interface Datenblatt :
3.2 Passive Mode : In the passive mode, the PC performs
Active Mode : ...programs are processed by the microprocessor.

Aber : Robo Pro (+ Connect Box) unterstützt kein Download, LLWin sehrwohl.

Gruß Ulrich Müller

heiko
Beiträge: 256
Registriert: 28 Okt 2010, 17:10

Re: Braucht Hilfe von altem LLWin Software

Beitrag von heiko » 18 Okt 2011, 13:11

Hi,

some USB/RS232 adapters are known to cause problems. Try the usual tricks, e.g. rebooting, attaching the adapter cable before startup, after startup, check if reconnecting breaks anything etc.. While this shouldn't be the case, I suggest trying another computer, preferably one with a native RS232 port to track down the error.

There are expensive "Mac-compatible" adapters by Keyspan, which, well, work more often than the cheap ones. A permanent solution is to attach the interface via RS232-ExpressCard if your computer has the slot. ExpressCard is native PCI express, so native, real-time capable UART chips can be used.

Besides, judging by your nickname and language of LLWin ... if your native language is German, feel free to use it. Also, fischerwerke still supports the "old" products, so a phone call to Schwarzwald (in any language) might be worth a try.

Grüße
Heiko

Benutzeravatar
FeuerTischler
Beiträge: 13
Registriert: 18 Okt 2011, 04:02

Re: Braucht Hilfe von altem LLWin Software

Beitrag von FeuerTischler » 19 Okt 2011, 03:17

thank you all for your responses!

"Downloading of programs for the Intelligent Interface is not supported by RoboPro"
i see, so the new versions have a different concept then.

_ _ _


hallo Heiko,

"Besides, judging by your nickname and language of LLWin"
actually i only speak "ein bisschen Deutsch" ;-)
but now that you mention it, it's strange that the error message is in German when i'm actually using the english program; or maybe this error message was just left untranslated ?

"some USB/RS232 adapters are known to cause problems."
i'm not sure the problem is the cable connection; the LLWin has a menu of "Setup Interface" to choose COM1/COM2 etc, and then a "Check Interface" where we can test the connection; M1 & M2 controlled via mouse clicks, and also indicators when the switches E1 to E4 are active.

these all work okay, it's when i try to download to the Interface that the error occurs, this tells me it's the program itself.
(possibly related to why the new version has NO download ?? but then why was i able to succeed the very first time ?)

i guess it's just a case of obsolete technology ??

thanks again for your feedback.
give them NOT fish, but TEACH them HOW TO

heiko
Beiträge: 256
Registriert: 28 Okt 2010, 17:10

Re: Braucht Hilfe von altem LLWin Software

Beitrag von heiko » 19 Okt 2011, 12:12

Huh. To be honest, I have no idea what could go wrong here ... just try to contact fischerwerke by e-mail, the "Kontakt mit ft"-Forum or by phone.

Heiko

UMueller
Beiträge: 220
Registriert: 31 Okt 2010, 22:58

Re: Braucht Hilfe von altem LLWin Software

Beitrag von UMueller » 19 Okt 2011, 15:56

Hallo,

on Vista 32bit and LLWin 3.0 I use an USB Serial Port Plug and the standard COM cable on COM3 that works.
with an other 232 Converter (U232-P9) cable it doesn't work (the Converter runs correct is said)
on an older Win2000 PC it works with an pure COM cable

works means download too


Gruß Ulrich Müller

Benutzeravatar
FeuerTischler
Beiträge: 13
Registriert: 18 Okt 2011, 04:02

Re: Braucht Hilfe von altem LLWin Software

Beitrag von FeuerTischler » 19 Okt 2011, 17:50

Heiko, thanks - i guess i will have to try that.

Ulrich, thanks for that feedback - i guess it's possible it is the cable also.

what about the file "temp.att" - have you ever seen that file extension on a FT project before ?
(maybe that's the USB-RS232 cable requirement ?? - but then it's in the LLWin 'temp' directory... :? )

i noticed a "tmp.q" file is created during the download process (in "LLWin210e\temp" - what happens in LLWin 3.0 ?
give them NOT fish, but TEACH them HOW TO

UMueller
Beiträge: 220
Registriert: 31 Okt 2010, 22:58

Re: Braucht Hilfe von altem LLWin Software

Beitrag von UMueller » 19 Okt 2011, 19:33

Hallo,

with LLWin 3.05 on Win2000 I had after Download in the directory \TEMP of LLWin the files :
TMP.ATT, TMP001.LST, TMP001.MVL, TMP001.Q
On the Vista System there are none.

Gruß Ulrich Müller

Benutzeravatar
FeuerTischler
Beiträge: 13
Registriert: 18 Okt 2011, 04:02

Re: Braucht Hilfe von altem LLWin Software

Beitrag von FeuerTischler » 20 Okt 2011, 06:15

ahh, so it is a fischertechnik generated file.

thank you very much Ulrich, i will use these as explanatory conditions to follow up with fischerwerke Tech Support.
give them NOT fish, but TEACH them HOW TO

Antworten