Raspberry PI

Alles rund um TX(T) und RoboPro, mit ft-Hard- und Software
Computing using original ft hard- and software
Forumsregeln
Bitte beachte die Forumsregeln!
Benutzeravatar
Defiant
Beiträge: 346
Registriert: 31 Okt 2010, 21:42
Wohnort: Narn Homeworld
Kontaktdaten:

Re: Raspberry PI

Beitrag von Defiant » 02 Jul 2013, 20:55

Kannst du zu diesem Zeitpunkt die CPU-Last beobachten? Mit "top" oder so.

thomasm
Beiträge: 47
Registriert: 29 Jun 2013, 21:48
Wohnort: Bochum

Re: Raspberry PI

Beitrag von thomasm » 03 Jul 2013, 21:29

Der r-pi scheint sich noch zu langweilen. Es hat auch nicht unbedingt etwas mit der java vm zu tun. Wenn ich examples/example ausführe, kommt es auch zu Fehlermeldungen mit Motorstottern.

Benutzeravatar
Defiant
Beiträge: 346
Registriert: 31 Okt 2010, 21:42
Wohnort: Narn Homeworld
Kontaktdaten:

Re: Raspberry PI

Beitrag von Defiant » 03 Jul 2013, 21:32

Auch zu dem Zeitpunkt wenn die Fehlermeldungen kommen?

thomasm
Beiträge: 47
Registriert: 29 Jun 2013, 21:48
Wohnort: Bochum

Re: Raspberry PI

Beitrag von thomasm » 03 Jul 2013, 21:55

Evtl. ist top nicht das richtige Werkzeug, um die kurzzeitigen Aussetzer zu messen. Ich kann keine Ausschläge beim CPU-Verbrauch erkennen.

Bei mir sieht das so aus:

Tasks: 91 total, 1 running, 90 sleeping, 0 stopped, 0 zombie
%Cpu(s): 1.4 us, 1.7 sy, 0.0 ni, 96.2 id, 0.0 wa, 0.0 hi, 0.7 si, 0.0 st
KiB Mem: 383752 total, 323760 used, 59992 free, 26408 buffers
KiB Swap: 102396 total, 0 used, 102396 free, 222008 cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
3563 pi 20 0 10120 736 588 S 3.9 0.2 0:02.47 ./example
3565 pi 20 0 4664 1436 1056 R 2.0 0.4 0:01.30 top
1611 root 20 0 1744 528 436 S 0.3 0.1 0:02.62 /usr/sbin/ifplugd -i wlan0 -q -f -u0 -d10 -w -I
2505 pi 20 0 15256 11m 2580 S 0.3 3.1 0:40.28 Xtightvnc :1 -desktop X -auth /home/pi/.Xauthority -geometry 1024x768 -depth
3541 pi 20 0 9804 1628 996 S 0.3 0.4 0:00.34 sshd: pi@pts/1
...

Benutzeravatar
Defiant
Beiträge: 346
Registriert: 31 Okt 2010, 21:42
Wohnort: Narn Homeworld
Kontaktdaten:

Re: Raspberry PI

Beitrag von Defiant » 04 Jul 2013, 11:52

Kann das Problem mit meinem R-Pi bestätigen. Da es mit dem BeagleBone Black einwandfrei funktioniert, vermute ich das Problem liegt am kaputten USB-Contoller des PIs.
Leider kann ich da nix machen.

Chrisir
Beiträge: 5
Registriert: 26 Mai 2014, 18:32

Re: Raspberry PI

Beitrag von Chrisir » 27 Mai 2014, 20:47

hallo,

das klingt interssant, ich habe ein altes intelligent interface

http://ft-datenbank.de/details.php?Arti ... 49c9c5fe2e

könnte ich theoretisch den Rasberry Pi auf den mobilen Roboter aufsetzen und fahren? Also nicht im Download-Modus, sondern im Online-Modus?

Aber unter Linux läuft doch LLWin sicher nicht. Was sind meine Alternativen?

Vielen Dank!

Beste Grüße,

Chris

Benutzeravatar
miharix
Beiträge: 1
Registriert: 23 Apr 2014, 14:24
Wohnort: Ljubljana - SLO
Kontaktdaten:

Re: Raspberry PI

Beitrag von miharix » 22 Jun 2014, 21:24

Hallo Fischertechnik freunde!

Ich unterrichte in meine Grundschule seit letztem Jahr Robotik.
Weil ich momentan keine Robotik komplette kaufen darf habe ich mir vorgenommen,
die FT komplette die die meine Schule schon sind, mit Rasberry Pi zu verbinden.

Und nach der Entwicklung des Moduls(FischPiMix) erbauten meine Schulkinder: https://www.youtube.com/watch?v=ODTY9RQhn2A :D

Hier noch der erster Modul Test: https://www.youtube.com/watch?v=leHwTYAQO-k

Benutzeravatar
steffalk
ft:pedia-Herausgeber
Beiträge: 1469
Registriert: 01 Nov 2010, 16:41
Wohnort: Karlsruhe
Kontaktdaten:

Re: Raspberry PI

Beitrag von steffalk » 23 Jun 2014, 13:49

Tach auch!

Das ist ja sagenhaft! Gratuliere herzlich - weiter so!

Gruß,
Stefan

Antworten