TX-Pi, Raspberry Pi Community-Controller

Community-Firmware (cfw), Selbstbaucontroller (TX-Pi, ftduino, usw.), 3D-gedrucktes Zubehör, usw
Forumsregeln
Bitte beachte die Forumsregeln!
flutehead
Beiträge: 7
Registriert: 08 Apr 2019, 20:14

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von flutehead » 08 Apr 2019, 23:14

Hallo @MasterOfGizmo,
nein, der ftduino wird überhaupt nicht mehr als USB-Gerät erkannt, weder vom TX-PI noch von meinem Notebook (über die Arduino-IDE). Der Reset-Knopf löst das Blinken der roten LED aus, aber dann passiert eben nichts, weil ja gar keine Verbindung existiert.
Ich kann mir noch nicht ganz erklären, wie ich das geschafft habe, aber auf dem Weg "ftduino vom TX-PI abstecken und am Notebook wieder anstecken" muss es wohl irgendwo im USB-Port gefunkt haben...
Achso, es läuft auch kein Sketch, ich war ja gerade dabei, nach dem ftduino-connect wieder den BlinkO1-Sketch hochzuladen.
Viele Grüße,
Jörg

PHabermehl
Moderator
Beiträge: 1296
Registriert: 20 Dez 2014, 22:59
Wohnort: Bad Hersfeld

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von PHabermehl » 08 Apr 2019, 23:55

Hallo Jörg,

da die Flinte ins Korn zu werfen, bringt auch nix. Der ftDuino ist ja nun auch "nur" ein Arduino, d.h., bei gleicher Behandlung stürbe der Eine so wie der Andere...
Till - MasterOfGizmo - wird Dir da sicher weiterhelfen.

Hast Du auf dem TX-Pi ftDuinIO installiert? Was zeigt das als Verbindungsstatus? "fail" oder "no ftDuino found"?

Wenn es "nur" ein "fail" ist, kannst Du mit ftDuinIO gleich das ftduino_direct hex-file flashen, dann sollte er spätestens nach einem re-scan auch wieder unter ftDuinIO ansprechbar sein.

Gruß
Peter
Moderative Beiträge sind explizit gekennzeichnet!

flutehead
Beiträge: 7
Registriert: 08 Apr 2019, 20:14

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von flutehead » 09 Apr 2019, 08:38

Guten Morgen,
ich werde heute abend mal weitertesten. ftDuinIO sagt "no ftDuino found", und wechselt nur kurz auf "fail" während der Reset/Flash-Periode. Vielleicht schaffe ich es, im richtigen Moment zu klicken ...
Vielen Dank für den schnellen und ausführlichen Support bislang!!
Viele Grüße,
Jörg

PHabermehl
Moderator
Beiträge: 1296
Registriert: 20 Dez 2014, 22:59
Wohnort: Bad Hersfeld

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von PHabermehl » 09 Apr 2019, 08:40

Wenn er fail anzeigt, dann spricht er auch noch!
Moderative Beiträge sind explizit gekennzeichnet!

Benutzeravatar
MasterOfGizmo
Beiträge: 1747
Registriert: 30 Nov 2014, 07:44

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von MasterOfGizmo » 09 Apr 2019, 12:09

flutehead hat geschrieben:Der Reset-Knopf löst das Blinken der roten LED aus, aber dann passiert eben nichts, weil ja gar keine Verbindung existiert.
Es ist äußerst unwahrscheinlich, dass er Schaden genommen hat (und wenn doch, dann bekommen wir das geregelt). Die Frage ist, ob er während die rote LED blinkt erkannt wird. Der ftDuino kennt zwei komplett unabhängige Betriebszustände: Den Normalbetrieb wenn der Sketch läuft (da hast Du gerade das Problem) und den Bootloaderbetrieb, wenn die LED so sanft hell-dunkel-blendet. Er verhält sich auch auf USB-Seite in beiden Fällen verschieden. Die Frage ist, ob er im Bootloaderbetrieb erkannt wird.

Das wäre zum Beispiel der Fall, wenn man während des Flashens den USB-Stecker abzieht oder ähnlich. Dann ist der normale Sketch defekt, und dann geht im Normalbetrieb auch USB nicht mehr. Aber der Bootloader sollte nach wie vor funktionieren und dieser Hinweis zur Benutzung des Reset-Knofes sollte helfen: https://harbaum.github.io/ftduino/www/m ... html#1.3.2
ftDuino, der Arduino für fischertechnik: http://ftduino.de

flutehead
Beiträge: 7
Registriert: 08 Apr 2019, 20:14

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von flutehead » 09 Apr 2019, 17:08

So - geschafft, BlinkO1 läuft wieder!
Ich war zu langsam auf dem TX-PI: Während der Bootphase auf scan, klicken, nicht vom "fail" irritieren lassen und sofort "Flash Binary" starten - das hat geholfen.
Es hilft doch immer wieder, mal eine Nacht vergehen zu lassen ...
Viele Grüße,
Jörg

Benutzeravatar
MasterOfGizmo
Beiträge: 1747
Registriert: 30 Nov 2014, 07:44

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von MasterOfGizmo » 09 Apr 2019, 17:20

Sehr schön. Freut mich.
ftDuino, der Arduino für fischertechnik: http://ftduino.de

tintenfisch
Beiträge: 85
Registriert: 03 Jan 2018, 22:04

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von tintenfisch » 18 Apr 2019, 22:01

Vor ein paar Tagen sind zwei Zero WH eingetrudelt, die eigentlich für andere Sachen gedacht waren, aber ich habe mal aus Neugier heute Abend das 3,2" Display und die SD-Karte vom Raspberry Pi abgezupft und beides an einem der Zeros verwendet.
Funktioniert. :) Das soll nun keine Empfehlung sein, zumal der Bootvorgang recht lange dauert und der Splash-Screen nicht angezeigt wurde (letzteres liegt vielleicht auch daran, dass das keine "reine" TX-Pi-Installation ist, sondern ich daran herumgefummelt habe), aber nett zu wissen, bzw. unter "Fakten, die die Welt nicht braucht" ablegen. :)

Benutzeravatar
MasterOfGizmo
Beiträge: 1747
Registriert: 30 Nov 2014, 07:44

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von MasterOfGizmo » 24 Apr 2019, 20:39

Mein neues Lieblingsdisplay am TX-Pi:

https://ebay.us/M8BJWq

Das ist kompatibel zum Waveshare 35a und läuft auch mit dessen Treiber. Aber: Man kann es mit 125Mhz SPI-Takt betreiben. Damit ist die Bilddarstellung sehr flott. Dieses Displays haben 320x480 Pixel bei 16-Bit Farbtiefe. Ein Bild besteht also aus 320x480*2=307200 Bytes. Bei 125 Mhz SPI-Takt können 125000000/8=15625000 Bytes/Sek übertragen werden. Bei 307200 Bytes/Bild sind das immerhin 50,86 FPS. Das reicht sogar für flüssiges Video und Spiele. Und es ist auch mechanisch kompatibel und passt genau in das Gehäuse, das wir für das Waveshare 35a entworfen haben.

Zum Vergleich: Die üblichen Noname-Displays dieser Art schaffen 16Mhz und damit 6,5 FPS. Das ist kaum zu ertragen.

Das Stichwort bei der Suche ist "MHS" und auf den Fotos sieht man immer den quadratischen Chip auf der Rückseite. Daran dürfte das in den meisten China-Shops eindeutig zu erkennen sein.
ftDuino, der Arduino für fischertechnik: http://ftduino.de

tintenfisch
Beiträge: 85
Registriert: 03 Jan 2018, 22:04

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von tintenfisch » 25 Apr 2019, 11:22

MasterOfGizmo hat geschrieben:Mein neues Lieblingsdisplay am TX-Pi:

https://ebay.us/M8BJWq

[...]
Danke, ich habe mal eines bestellt.

OT: Mit dem richtigen Treiber sollten auch die anderen Displays wesentlich bessere Ergebnisse bieten können. Hier ein interessantes Projekt: https://github.com/juj/fbcp-ili9341
Leider bietet der Treiber nur eine schnelle Ausgabe, die Touch-Events werden nicht unterstützt, somit ist das Projekt (derzeit) nutzlos für den TX-Pi. Vielleicht interessiert es jemanden dennoch. Es ist erstaunlich, was mit dem Treiber herausgeholt werden kann: https://www.youtube.com/watch?v=dqOLIHOjLq4

Benutzeravatar
MasterOfGizmo
Beiträge: 1747
Registriert: 30 Nov 2014, 07:44

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von MasterOfGizmo » 25 Apr 2019, 12:42

tintenfisch hat geschrieben: Leider bietet der Treiber nur eine schnelle Ausgabe, die Touch-Events werden nicht unterstützt, somit ist das Projekt (derzeit) nutzlos für den TX-Pi. Vielleicht interessiert es jemanden dennoch. Es ist erstaunlich, was mit dem Treiber herausgeholt werden kann: https://www.youtube.com/watch?v=dqOLIHOjLq4
In der Tat erstaunlich.

Der Touchscreen hat aber eigentlich nichts mit dem Display-Treiber zu tun. Das sind weitgehend unabhängige Teile, ausser dass sie den gleichen SPI benutzen, aber das sollten die Hardwaretreiber koordiniert bekommen.

Ich habe diese Treiber auch mal ausprobiert, aber so schrecklich toll funktionierte das da nicht. Und wenn sich der gesamte Bildinhalt ändert, weil ein Spiel z.B. scrollt, dann nützt das eigentlich überhaupt nichts, denn es müssen ja alle Pixel neu übertragen werden. Man kann den SPI einiger normaler Displays auf 40Mhz takten, aber meiner Erfahrung nach ist das reines Glücksspiel. Manche laufen nur bei 16Mhz. In dem Video benutzen sie zum Vergleich ein Waveshare auf 32Mhz mit normalem fbcp. Das lässt das normale Display aber auch schlechter aussehen, als es ist, weil dort x-mal hin- und herkopiert wird. Bei 32 Mhz sollte das normale Display auch 13 FPS schaffen und flüssiger aussehen. Der TX-Pi benutzt ja gar kein fbcp sondern der Treiber schreibt direkt ins Display, Das sollte bei 32Mhz besser aussehen als die schlechte Variante im Video.

Und das MHS-Display ist ja nichtmal teurer aus diese anderen.
ftDuino, der Arduino für fischertechnik: http://ftduino.de

tintenfisch
Beiträge: 85
Registriert: 03 Jan 2018, 22:04

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von tintenfisch » 04 Mai 2019, 11:29

Hallo zusammen,

wir haben ein neues Setup-Script für den TX-Pi veröffentlicht.
Das Setup unterstützt nun auch Waveshare 3,5" B revision 2.0 Displays; zudem hat der TX-Pi eine neue App zum Starten / Stoppen des SSH- und VNC-Servers bekommen, welche die alte SSH / VNC App ersetzt und auch weitere Konfigurationmöglichkeiten (I²C-Bus, Display, Hostname) bietet.

Bestehende Installationen können durch das erneute Herunterladen des Setup-Scripts aktualisiert werden:

Code: Alles auswählen

wget https://tx-pi.de/tx-pi-setup.sh
sudo bash ./tx-pi-setup.sh
Installation für das 3,5" A Display

Code: Alles auswählen

sudo bash ./tx-pi-setup.sh LCD35
Installation für das 3,5" B Display

Code: Alles auswählen

sudo bash ./tx-pi-setup.sh LCD35B
Installation für das 3,5" B rev. 2.0 Display

Code: Alles auswählen

sudo bash ./tx-pi-setup.sh LCD35BV2
Weitere Informationen findet Ihr auf der Github-Seite https://github.com/ftCommunity/tx-pi sowie auf der Homepage https://www.tx-pi.de/de/installation/

Neue SD-Images folgen in Kürze und werden wahrscheinlich durch @PHabermehl hier angekündigt.

Viele Grüße
Lars
Zuletzt geändert von tintenfisch am 04 Mai 2019, 21:41, insgesamt 1-mal geändert.

Benutzeravatar
mbartelt
Beiträge: 56
Registriert: 17 Apr 2011, 17:16
Wohnort: Kerpen-Balkhausen
Kontaktdaten:

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von mbartelt » 04 Mai 2019, 20:20

Hi,

habe meine alte Installation dann mal geupdated. Lief soweit ohne Probleme durch. Was mir nun auffällt, oder ich habe es auf den Augen, wo ist die App zum kallibrieren des Displays geblieben? Die ist eindeutig weg.

Gruß

Manfred
Meine ft Baukasten-Galerie: http://www.mannis-world.de/ft

tintenfisch
Beiträge: 85
Registriert: 03 Jan 2018, 22:04

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von tintenfisch » 04 Mai 2019, 20:28

mbartelt hat geschrieben: [...] Was mir nun auffällt, oder ich habe es auf den Augen, wo ist die App zum kallibrieren des Displays geblieben? Die ist eindeutig weg.
Ups. Wir hatten zwar die App zum Kalibireren ausgetauscht, aber ganz weg sollte die eigentlich nicht sein. Ich schau mir das an und melde mich.
Du kannst die Installation zunächst so lassen, wir bekommen die TS-Cal App wieder zurück, Du wirst dann einfach wieder das Setup ausführen müssen.

Benutzeravatar
mbartelt
Beiträge: 56
Registriert: 17 Apr 2011, 17:16
Wohnort: Kerpen-Balkhausen
Kontaktdaten:

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von mbartelt » 04 Mai 2019, 20:33

tintenfisch hat geschrieben:Ups. Wir hatten zwar die App zum Kalibireren ausgetauscht, aber ganz weg sollte die eigentlich nicht sein. Ich schau mir das an und melde mich.
Danke für Deine Antwort. Warte dann mal ab.

Gruß

Manfred
Meine ft Baukasten-Galerie: http://www.mannis-world.de/ft

tintenfisch
Beiträge: 85
Registriert: 03 Jan 2018, 22:04

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von tintenfisch » 04 Mai 2019, 21:01

Hallo Manfred,

ich kann das Problem leider nicht nachvollziehen / bestätigen. Ich habe das nun mit zwei Installationen versucht und jedes Mal hatte ich die (neue) TS-Cal App im System-Ordner.
Ausführbar ist sie auch.

Ist das Setup komplett durchgelaufen? Welche Raspbian Version nutzt Du? Jessie oder Stretch (cat /etc/debian_version)?

Evtl. hilft es, das Setup noch einmal auszuführen?

Hat noch jemand das Problem?

Ich habe, abgesehen von einer nicht korrekten Ausführung des Scripts (bspw. Internetverbindung war kurz weg etc.), keine Idee, woran es liegen kann.

Viele Grüße
Lars

PS: Findest Du die "Config" im System-Ordner? Eigentlich sollte nach der Installation / einem Update der System-Ordner so aussehen:
txpi-system.png

PHabermehl
Moderator
Beiträge: 1296
Registriert: 20 Dez 2014, 22:59
Wohnort: Bad Hersfeld

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von PHabermehl » 04 Mai 2019, 21:32

Ich lasse gerade das script als update über eine alte Jessie-Installation laufen. Melde mich danach...
Moderative Beiträge sind explizit gekennzeichnet!

PHabermehl
Moderator
Beiträge: 1296
Registriert: 20 Dez 2014, 22:59
Wohnort: Bad Hersfeld

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von PHabermehl » 04 Mai 2019, 22:15

Ok, auch bei dem Durchlauf war alles okay!

Manni, leider können wir das Problem momentan nicht nachstellen...

Gruß
Peter
Moderative Beiträge sind explizit gekennzeichnet!

PHabermehl
Moderator
Beiträge: 1296
Registriert: 20 Dez 2014, 22:59
Wohnort: Bad Hersfeld

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von PHabermehl » 05 Mai 2019, 02:26

Hallo zusammen,

die aktuellen TX-Pi Images sind fertig und auf GitHub zu finden:
https://github.com/ftCommunity/tx-pi/re ... 2019-05-05

Sobald Lars die Webseite geupdatet hat, werden sie auch auf tx-pi.de sein.

Gruß
Peter
Moderative Beiträge sind explizit gekennzeichnet!

tintenfisch
Beiträge: 85
Registriert: 03 Jan 2018, 22:04

Re: TX-Pi, Raspberry Pi Community-Controller

Beitrag von tintenfisch » 05 Mai 2019, 09:14

Hatter. ;)

Warum Du keine Schreibrechte hast, weiß ich leider nicht, müssen wir noch klären.

Die neuen Images sind unter https://www.tx-pi.de/images/ zu finden.

Danke!

Antworten