TXT Zeitmessung fehlerhaft

Hier habt Ihr die Möglichkeit direkt mit dem fischertechnik Team in Kontakt zu treten
Here you have the Possibility to get in direct contact with the fischertechnik-Team

Moderator: fischertechnik Mitarbeiter

Forumsregeln
Bitte beachte die Forumsregeln!

In dieser Unterkategorie können nur fischertechnik-Mitarbeiter und Moderatoren antworten!
Gesperrt
hamlet
Beiträge: 313
Registriert: 12 Jan 2011, 21:41

TXT Zeitmessung fehlerhaft

Beitrag von hamlet » 03 Jan 2016, 13:08

Hallo ft-Team,
Folgendes RoboPro-Programm rahmt ein einfaches 100ms "Warten"-Element mit zwei unabhängigen Zeitmessungen ein. Die erste erfolgt mit einer klassischen Timer-Variablen und die zweite unter Verwendung des neuen Timer-Tick-Eingangs. Die Messungen werden ständig wiederholt, wobei die maximalen Abweichungen der Messungen zum Zielwert und untereinander ausgegeben werden:
timerTest.rpp
Mit RoboPro 4.2.3 offline auf dem TXT ergeben sich Abweichungen der beiden Messungen von bis zu 50ms, sowohl zum Zielwert von 100ms als auch untereinander. Bei einem 20ms Zielwert ist die Abweichung ebenfalls bis zu 50ms groß.
Entweder wird der Programmablauf unvorhersehbar und massiv unterbrochen oder die Timer sind fehlerhaft. Auf jeden Fall ist in diesem Zustand der TXT für eine Zeitmessung unbrauchbar.
Beste Grüße,
Helmut

Markus Burkhardt
Beiträge: 171
Registriert: 12 Jan 2016, 09:13

Re: TXT Zeitmessung fehlerhaft

Beitrag von Markus Burkhardt » 14 Jan 2016, 10:00

Hallo Helmut,

ich habe deine Messungen auch mal durchgeführt und konnte deine Ergebnisse nachvollziehen. Ich kann dir leider auf die Schnelle keine Lösung anbieten, jedoch kann ich dir versichern, dass wir das jetzt dank dir auf dem Schirm haben und hoffentlich zeitnah beheben können (hoffentlich mit dem nächsten Update).

Viele Grüße
Markus

hamlet
Beiträge: 313
Registriert: 12 Jan 2011, 21:41

Re: TXT Zeitmessung fehlerhaft

Beitrag von hamlet » 14 Jan 2016, 18:38

Hallo Markus,
Prima! Vielen Dank für die Rückmeldung.
Beste Grüße,
Helmut

Markus Burkhardt
Beiträge: 171
Registriert: 12 Jan 2016, 09:13

Re: TXT Zeitmessung fehlerhaft

Beitrag von Markus Burkhardt » 18 Jan 2016, 18:03

Hallo Helmut,

diese Delays werden vom Display verursacht. Jedes Mal wenn das Display aktualisiert wird, kommt es zu einer kurzen Verzögerung. Um deine Zeitmessung korrekt durchzuführen, musst du erst deine Berechnungen/Messungen machen und anschließend eine Ausgabe machen. Dann sollte das Ergebnis stimmen. Diese unschöne Verhalten werden wir hoffentlich demnächst beseitigen können.

Viele Grüße
Markus

davidrpf
Beiträge: 211
Registriert: 14 Jul 2015, 14:27
Kontaktdaten:

Re: TXT Zeitmessung fehlerhaft

Beitrag von davidrpf » 18 Jan 2016, 19:06

Hallo Herr Burkhardt,

ich benötige aktuell eine ziemlich exakte Zeitmessung für ein Projekt, verwende dabei aber den TX Controller. Verglichen mit den Zeiten, die der Arduino Uno unter den selben Bedingungen misst, sind die des TX Controllers um 10 - 15 % größer (d.h. ungenauer) (im Bereich bis 100ms). Ich habe dabei keine parallelen Prozesse am laufen.
Liegt das am TX Controller oder an der Umsetzung des RoboPro Codes auf Maschinen Code? Würde ein mit C geschriebenes Programm Abhilfe schaffen?

Gruß, David
Polarkoordinaten Plotter https://youtu.be/u6XwKxZuxqk
Autofabrik: https://youtu.be/mX9JWcca6kQ

hamlet
Beiträge: 313
Registriert: 12 Jan 2011, 21:41

Re: TXT Zeitmessung fehlerhaft

Beitrag von hamlet » 18 Jan 2016, 21:16

Hallo Markus,
Ich hatte beim Design des Tests schon darauf geachtet, dass die eigentliche Zeitmessung nicht durch Display-Zugriffe gestört wird: Die Zeitmessung und Berechnung ist durch Zuweisungsbefehle von den Displayausgängen entkoppelt. Die Zuweisung an die Displayausgänge erfolgt erst nach der Messung.

Die Display-Aktualisierung hatte ich auch schon in Verdacht. Darum habe ich im Test-Programm zwischen der Display-Ausgabe am Ende der Testschleife und einem neuem Test-Durchlauf ein zusätzliches Warten-Element (1s) eingeführt, um dem TXT Zeit für die Display-Aktualisierung zu geben. Damit bessert sich die Situation ein wenig: Immer noch bis zu 25ms Abweichung. Evtl. grätschen da noch andere System-Tasks zwischen.

Allerdings lässt sich damit nicht erklären, dass manchmal eine Zeit kleiner der geforderten 100ms gemessen wird. Da scheint auch noch etwas beim Timer bzw. Ticker-Update schiefzulaufen.

Bezüglich des TXT-Timings ist vielleicht noch folgender Beitrag interessant. (… Ich bitte mir meine teils leicht spitzen Formulierungen nachzusehen.)
Beste Grüße,
Helmut

Markus Burkhardt
Beiträge: 171
Registriert: 12 Jan 2016, 09:13

Re: TXT Zeitmessung fehlerhaft

Beitrag von Markus Burkhardt » 19 Jan 2016, 15:16

Hallo Helmut,

ich habe dein Programm noch einmal ein bisschen modifiziert und damit komme ich auf max. Verzögerung von ca. 11 ms. Das Programm findest du hier:
https://oc.ugfischer.com/public.php?ser ... cd8d9038fe
Ich finde aber auch 11ms noch zu viel. Ich bleib dran.

Viele Grüße
Markus

hamlet
Beiträge: 313
Registriert: 12 Jan 2011, 21:41

Re: TXT Zeitmessung fehlerhaft

Beitrag von hamlet » 19 Jan 2016, 19:16

Hallo Markus,
ich kann die Ergebnisse mit Deiner modifizierten Version (Ausgabe aufs Display am Ende des Programms) reproduzieren: Maximal 12ms Abweichungen.
Verglichen mit den 50ms in meiner vorherigen Version ist das ein großer Schritt in die richtige Richtung.
Also, wenn's auf's Timing ankommt, das Display mit Bedacht einsetzen.
Allerdings ist das Display auch die einzige Möglichkeit Debug Infos im Offline-Betrieb anzuzeigen. (... Ich träum ja immer noch von der Möglichkeit, dass der Text-Befehl optional in eine Datei oder auf die Konsole schreiben kann.)
Ich finde aber auch 11ms noch zu viel. Ich bleib dran.
Großartig, Vielen Dank!

Beste Grüße,
Helmut

Benutzeravatar
Dirk Haizmann ft
fischertechnik Mitarbeiter
Beiträge: 1126
Registriert: 09 Nov 2010, 08:48

Re: TXT Zeitmessung fehlerhaft

Beitrag von Dirk Haizmann ft » 21 Jan 2016, 16:48

.. damit wär da Thema ja geklärt.

DANKE Markus

ft

Gesperrt