TX-Pi, Raspberry Pi Community-Controller

Community-Firmware (cfw), Selbstbaucontroller (TX-Pi, ftduino, usw.), 3D-gedrucktes Zubehör, usw
Forumsregeln
Bitte beachte die Forumsregeln!

Re: TX-Pi, Raspberry Pi Community-Controller

Beitragvon mbartelt » 05 Mai 2019, 10:56

Guten Morgen,

Hatte das vorige Image benutzt und gestern über das Setup Script geupdated. Werde mir dann mal das neue Image herunterladen. Vielen Dank für Eure Hilfe.

Gruß

Manfred

PS

Gerade installiert und in Betrieb genommen. Alles wieder in Ordnung!
Meine ft Baukasten-Galerie: http://www.mannis-world.de/ft
Benutzeravatar
mbartelt
 
Beiträge: 56
Registriert: 17 Apr 2011, 17:16
Wohnort: Kerpen-Balkhausen
Alter: 55

Re: TX-Pi, Raspberry Pi Community-Controller

Beitragvon tintenfisch » 12 Mai 2019, 20:24

MasterOfGizmo hat geschrieben:Mein neues Lieblingsdisplay am TX-Pi:

https://ebay.us/M8BJWq

Das ist kompatibel zum Waveshare 35a und läuft auch mit dessen Treiber. Aber: Man kann es mit 125Mhz SPI-Takt betreiben. Damit ist die Bilddarstellung sehr flott. Dieses Displays haben 320x480 Pixel bei 16-Bit Farbtiefe. Ein Bild besteht also aus 320x480*2=307200 Bytes. Bei 125 Mhz SPI-Takt können 125000000/8=15625000 Bytes/Sek übertragen werden. Bei 307200 Bytes/Bild sind das immerhin 50,86 FPS. Das reicht sogar für flüssiges Video und Spiele. Und es ist auch mechanisch kompatibel und passt genau in das Gehäuse, das wir für das Waveshare 35a entworfen haben.

Zum Vergleich: Die üblichen Noname-Displays dieser Art schaffen 16Mhz und damit 6,5 FPS. Das ist kaum zu ertragen.


Meins ist gestern angekommen. :)

Sogar recht vernünftig verpackt, in der üblichen graunen China-Tüte war ein Karton mit dem Display. Bisher habe ich die Displays immer nur in der Tüte mit etwas Luftpolsterfolie "geschützt" bekommen.

35mhs.jpg


Läuft auch flüssig und klar mit dem Waveshare 35a-Treiber, ich mußte die Rotation lediglich auf 0 setzen, ansonsten stünde es auf dem Kopf.

Hast Du bei Dir den SPI-Takt in der config.txt vorgegeben? Wenn ich dort nichts angebe, funktioniert alles. Sobald ich dort einen Wert angebe, bspw. "125000000" oder auch nur "80000000", leuchtet das Display nur weiß aber ich bekomme keine Ausgabe.
tintenfisch
 
Beiträge: 69
Registriert: 03 Jan 2018, 23:04

Re: TX-Pi, Raspberry Pi Community-Controller

Beitragvon MasterOfGizmo » 13 Mai 2019, 09:52

Ja, ich habe es auf 125000000 gestellt.
ftDuino, der Arduino für fischertechnik: http://ftduino.de
Benutzeravatar
MasterOfGizmo
 
Beiträge: 1639
Registriert: 30 Nov 2014, 08:44

Re: TX-Pi, Raspberry Pi Community-Controller

Beitragvon tintenfisch » 13 Mai 2019, 13:03

MasterOfGizmo hat geschrieben:Ja, ich habe es auf 125000000 gestellt.


Bei mir klappt das nicht, ich habe mir die Treiber aus dem Waveshare GH Repository geholt, weil die vermeintlich neueren Datums sind, aber auch der Treiber bringt keinerlei Verbesserung:
* 40 MHz: Bunte Farben (grün, gelb, etc.)
* 50 - 62 MHz: grünstichiges Blau mit Streifen
* 63 MHz und höher: Bildschirm leuchtet weiß, keine Ausgabe

FPS kann ich unabhängig davon auf 50 setzen, bringt aber gefühlt keine Änderungen / Verbesserungen.

Nachtrag:
Mein Platinenlayout sieht auch ganz anders aus als auf den Bildern des Angebotes, u.a. fehlt der markante, quadaratische Chip.
display-2019-05.jpg


Von den Chips her entspricht es etwa dem WS 3.5" A, welches ich habe. Dort sind die etwas anders aufgelötet, aber vergleichbar.

Auf den Bildern des Angebots ist zudem "SPI 150 MHz support" aufgedruckt. Diesen Aufdruck findet man auch bei Vergleichsbildern im Internet.
Ich habe auch noch einen alternativen Treiber (MHS35 von https://github.com/goodtft/LCD-show) mit dem gleichen Ergebnis "weißer Bildschrim" (auch ohne speed-Parameter) ausprobiert.

Ich vermute, ich habe einfach das falsche Display erhalten. :roll:
tintenfisch
 
Beiträge: 69
Registriert: 03 Jan 2018, 23:04

Re: TX-Pi, Raspberry Pi Community-Controller

Beitragvon PHabermehl » 13 Mai 2019, 14:34

tintenfisch hat geschrieben:Ich vermute, ich habe einfach das falsche Display erhalten. :roll:


Das Bild entspricht exakt dem "langsamen" Standard-Display, das ich habe... Deine Diagnose dürfte stimmen. --> Käuferschutz!

Gruß
Peter
Moderative Beiträge sind explizit gekennzeichnet!
PHabermehl
Moderator
 
Beiträge: 1208
Registriert: 20 Dez 2014, 23:59
Wohnort: Bad Hersfeld
Alter: 46

Re: TX-Pi, Raspberry Pi Community-Controller

Beitragvon MasterOfGizmo » 13 Mai 2019, 17:12

Damit sollte es beim richtigen Board gehen.

Code: Alles auswählen
dtoverlay=waveshare35a:rotate=0,speed=125000000


Und ja, das auf dem Bild ist definitiv eines der üblichen langsamen Displays. Es muss eine schwarze Platine mit dem Aufruck 125MHz sein. Alles anderere ist falsch. Schade, dass es Dich so erwischt hat. Aber in der Regel sind die chinesischen Lieferanten recht kooperativ.
ftDuino, der Arduino für fischertechnik: http://ftduino.de
Benutzeravatar
MasterOfGizmo
 
Beiträge: 1639
Registriert: 30 Nov 2014, 08:44

Re: TX-Pi, Raspberry Pi Community-Controller

Beitragvon tintenfisch » 13 Mai 2019, 20:23

MasterOfGizmo hat geschrieben:Damit sollte es beim richtigen Board gehen.

Code: Alles auswählen
dtoverlay=waveshare35a:rotate=0,speed=125000000


Und ja, das auf dem Bild ist definitiv eines der üblichen langsamen Displays. Es muss eine schwarze Platine mit dem Aufruck 125MHz sein. Alles anderere ist falsch. Schade, dass es Dich so erwischt hat. Aber in der Regel sind die chinesischen Lieferanten recht kooperativ.


Ja, genauso sah meine config.txt aus. :(

Danke für die Antworten, ich habe dem Lieferanten bereits geschrieben, mal schauen, was dabei herauskommt.
tintenfisch
 
Beiträge: 69
Registriert: 03 Jan 2018, 23:04

Re: TX-Pi, Raspberry Pi Community-Controller

Beitragvon tintenfisch » 17 Mai 2019, 21:51

Um das noch abzuschließen: Wir sind uns einig geworden und gestern habe ich ein weiteres MHS-Display bestellt, das sich hoffentlich bei Lieferung als MHS-Display herausstellt ;)
tintenfisch
 
Beiträge: 69
Registriert: 03 Jan 2018, 23:04

Vorherige

Zurück zu Community-Projekte

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast