nach gelungener Installation keine Informationen mehr

Alle APIs oder Firmwares für den TXT: Community-Firmware, .net, C++, usw.
Forumsregeln
Bitte beachte die Forumsregeln!

nach gelungener Installation keine Informationen mehr

Beitragvon FischRob » 08 Jul 2018, 17:11

Hallo,
ich habe gestern die neue Firmware auf den TXT aufgespielt. Jetzt habe ich ein paar Fragen:

Bei jedem Neustart stimmt das Datum und die Zeit nicht.
Bei store kommt die Fehlermeldung "Netzwerkfehler Server nicht gefunden" welche Daten brauche ich für welchen Server?
Wo finde ich ein tutorial und Beispele
Wie komme ich an die verschiedenen Programmiersprachen ?

Das soll es erst mal gewesen sei. Es sind dann sicherlich noch mehrere Fragen da ja Literatur total fehlt.

Mit besten Dank im Vorraus.

FischRob
FischRob
 
Beiträge: 54
Registriert: 01 Nov 2010, 10:51

Re: nach gelungener Installation keine Informationen mehr

Beitragvon MasterOfGizmo » 08 Jul 2018, 18:14

FischRob hat geschrieben:Es sind dann sicherlich noch mehrere Fragen da ja Literatur total fehlt.


Die Online-Anleitungen finden sich ja schnell unter http://cfw.ftcommunity.de und ich bin sicher, dass Du die Beiträge in der ftpedia auch leicht gefunden hast.

Daher meinst Du sicher, dass es keine gedruckten Handbücher gibt. Das ist wahr. Das scheitert in erster Linie an hohen Kosten. Vielleicht magst Du ja als Sponsor einspringen.
ftDuino, der Arduino für fischertechnik: http://ftduino.de
Benutzeravatar
MasterOfGizmo
 
Beiträge: 1344
Registriert: 30 Nov 2014, 08:44

Re: nach gelungener Installation keine Informationen mehr

Beitragvon FischRob » 08 Jul 2018, 18:24

Hallo,
die Information ist etwas mager.
Solange ich keine Verbindung zum Server unter store aufbauen kann geht gar nichts.
Die Informationen auf der Fischertechnik Seite habe ich gelesen da steht aber auch nicht wie ich die Addresse des Servers finde um weitere Programme zu laden.
Gruß
FischRob
FischRob
 
Beiträge: 54
Registriert: 01 Nov 2010, 10:51

Re: nach gelungener Installation keine Informationen mehr

Beitragvon sven » 08 Jul 2018, 19:06

Hallo!

Du meinst sicherlich nicht die ftc Firmware, sondern die original ft Firmware.
Die neuen Funktionen sind ja wohl für den neuen Baukasten.
ich denke mal das die von Dir gesuchten Infos in der Anleitung zum Baukasten sind.
Daher gehen ich davon aus das man diese Funktionen nur nutzen kann wenn man den Baukasten gekauft hat.

Gruß
sven
Benutzeravatar
sven
 
Beiträge: 1588
Registriert: 18 Okt 2010, 18:13
Wohnort: Rahden
Alter: 44

Re: nach gelungener Installation keine Informationen mehr

Beitragvon MasterOfGizmo » 08 Jul 2018, 19:23

Ich denke schon, dass er die cfw meint.

Du musst den Server nicht einstellen. Aber Du musst Dich mit dem TXT in Deinem WLAN anmelden und mit dem Internet verbunden sein. Wenn Du das nicht bist kann der Store auf seinen Server nicht zugreifen.

Dass die Zeit nicht stimmt ist wohl ein neuer Bug. Davon berichten auch andere User und auf github wurde ein Issue-Report deswegen aufgemacht.

Was Du mit dem Finden von Programmiersprachen meinst ist mir nicht ganz klar. Was erwartest Du zu finden?

Es kann gut sein, dass die Doku mager ist. Aber das lliegt auch daran, dass sich relativ viele Leute als reine Kunden sehen. Das ist schade, denn gerade Leute wie Du könnten eine super Dokumentation schreiben, wenn sie ihren eigenen Weg dokumentieren würden.
ftDuino, der Arduino für fischertechnik: http://ftduino.de
Benutzeravatar
MasterOfGizmo
 
Beiträge: 1344
Registriert: 30 Nov 2014, 08:44

Re: nach gelungener Installation keine Informationen mehr

Beitragvon FischRob » 08 Jul 2018, 19:56

Hallo,
vielen Dank für Euer Interesse. Natürlich meine ich die CfW und ich bin natürlich mit Wlan verbunden. Wenn ich jetzt auf den Button store klicke kommt die Fehlermeldung "Netzwerkfehler Server nicht gefunden".
Unter Software meine ich die startIDE und Brickly.
Eventuell habe ich einen Fehler bei der Installation gemacht aber es funktioniert.
Einziger Unterschied: Ich habe unter der original FT-Oberfläche ein Programm aus Robopro auf den TXT geladen. Dieses Programm wird unter der CfW-Oberfläche (unter ft-gui) nicht gefunden. Nachdem ich das Programm erneut unter CfW geladen habe war es auch unter CfW verhanden. Jetzt habe ich halt diese Programm 2x auf dem TXT.
Gruß
FoschRob
FischRob
 
Beiträge: 54
Registriert: 01 Nov 2010, 10:51

Re: nach gelungener Installation keine Informationen mehr

Beitragvon MasterOfGizmo » 08 Jul 2018, 22:14

Wenn der Store seinen Server nicht erreicht, dann hat der TXT m.E. keinen vollen Internet-Zugriff. Und solange er den nicht hat kann er auch keine Apps runterladen. Du bist sicher, dass der TXT nicht nur im WLAN ist, sondern dass er auch vollen Zugriff auf's Internet hat?
ftDuino, der Arduino für fischertechnik: http://ftduino.de
Benutzeravatar
MasterOfGizmo
 
Beiträge: 1344
Registriert: 30 Nov 2014, 08:44

Re: nach gelungener Installation keine Informationen mehr

Beitragvon FischRob » 09 Jul 2018, 09:42

Bei meiner Fritzbox steht der TXT als verbunden. Was soll ich sonst noch einstellen. Da ich auch den WEB- server im Internet aufrufen kann, sehe ich keine Lösung.
FischRob
 
Beiträge: 54
Registriert: 01 Nov 2010, 10:51

Re: nach gelungener Installation keine Informationen mehr

Beitragvon PHabermehl » 09 Jul 2018, 09:59

Moin,
Du kannst also das webinterface der cfw aufrufen, indem Du im Webbrowser die IP des TXT eingibst?

Gruß
Peter
PHabermehl
 
Beiträge: 865
Registriert: 20 Dez 2014, 23:59
Wohnort: Bad Hersfeld
Alter: 45

Re: nach gelungener Installation keine Informationen mehr

Beitragvon FischRob » 09 Jul 2018, 13:54

Ja genau aber wenn ich auf store gehe bekomme ich "Netzwerkfehler Server nicht gefunden"
FischRob
 
Beiträge: 54
Registriert: 01 Nov 2010, 10:51

Re: nach gelungener Installation keine Informationen mehr

Beitragvon PHabermehl » 09 Jul 2018, 14:10

FischRob hat geschrieben:Ja genau aber wenn ich auf store gehe bekomme ich "Netzwerkfehler Server nicht gefunden"


Ich bin leider im Moment TXT-los und kann in den nächsten Tagen nix machen. Aber... Du kannst die Zip-Dateien der Apps aus dem store herunterladen und dann über das Webinterface installieren.

startIDE: https://github.com/ftCommunity/ftcommun ... artIDE.zip
brickly: https://github.com/ftCommunity/ftcommun ... rickly.zip
und dazu brickMCP: https://github.com/ftCommunity/ftcommun ... ickMCP.zip

Das löst das Problem zwar nicht, aber Du kannst mit startIDE und brickly spielen...

Gruß
Peter
PHabermehl
 
Beiträge: 865
Registriert: 20 Dez 2014, 23:59
Wohnort: Bad Hersfeld
Alter: 45

Re: nach gelungener Installation keine Informationen mehr

Beitragvon FischRob » 09 Jul 2018, 14:41

Vielen Dank für die Informationen aber wie Du schon sagst, das löst das Problem nicht.
FischRob
 
Beiträge: 54
Registriert: 01 Nov 2010, 10:51

Re: nach gelungener Installation keine Informationen mehr

Beitragvon EstherM » 09 Jul 2018, 17:56

FischRob hat geschrieben:Ja genau aber wenn ich auf store gehe bekomme ich "Netzwerkfehler Server nicht gefunden"

Ich habe jetzt mal mit einer frisch formatierten SD-Karte die aktuelle 0.9.4 ausgepackt. Nach der Verbindung mit dem WLAN lässt sich über die Store-App problemlos Brickly und startIDE installieren. Hier lässt sich das Problem also nicht reproduzieren.

FischRob hat geschrieben:Ich habe unter der original FT-Oberfläche ein Programm aus Robopro auf den TXT geladen. Dieses Programm wird unter der CfW-Oberfläche (unter ft-gui) nicht gefunden. Nachdem ich das Programm erneut unter CfW geladen habe war es auch unter CfW verhanden. Jetzt habe ich halt diese Programm 2x auf dem TXT.

Wenn ich das richtig verstanden habe (ich kenne mich mit Robopro und Robopro unter CFW aber nicht aus), ist das so. Das Robopro-Programm ist jetzt einmal auf dem TXT und dann nochmal auf der SD-Karte. Die CFW lebt ihr eigenes Leben auf ihrer SD-Karte und greift auf den Speicher im TXT nicht zu. Dafür kann sie auf die SD-Karte schreiben. Bevor ich das so in die Doku schreibe, sollte das aber noch mal jemand bestätigen.

Wenn du konkrete Wünsche an die Doku hast (http://cfw.ftcommunity.de), wird das bestimmt auch irgendwann umgesetzt.

Gruß
Esther
EstherM
 
Beiträge: 163
Registriert: 11 Dez 2011, 22:24

Re: nach gelungener Installation keine Informationen mehr

Beitragvon FischRob » 09 Jul 2018, 19:46

Hallo,
allen die mir hier geantwortet haben vielen Dank.

Ich habe das Problem gelöst.

In der Netzwerkeinstellung vom TXT habe ich zuerst meine IP eingegeben und zwar wie bei mir im gesamten Netzwerk statisch. Nun habe ich auf automatisch umgeschalten und siehe da,ich habe keine Fehlermeldung mehr und der store funktioniert.
Also allen nochmals vielen Dank.

Gruß
FischRob
FischRob
 
Beiträge: 54
Registriert: 01 Nov 2010, 10:51

Re: nach gelungener Installation keine Informationen mehr

Beitragvon MasterOfGizmo » 09 Jul 2018, 20:01

Statische Adressen geht auch, aber Du musst natürlich Nameserver, Default-Gateway etc auch richtig setzen.
ftDuino, der Arduino für fischertechnik: http://ftduino.de
Benutzeravatar
MasterOfGizmo
 
Beiträge: 1344
Registriert: 30 Nov 2014, 08:44

Re: nach gelungener Installation keine Informationen mehr

Beitragvon FischRob » 10 Jul 2018, 14:12

Nachdem nun alles läuft habe ich mal mit Brickly angefangen.
Wie kann ich in Brickly speichern und Laden um an einem angefangenen Projekt weiterzuatbeiten?
FischRob
 
Beiträge: 54
Registriert: 01 Nov 2010, 10:51

Re: nach gelungener Installation keine Informationen mehr

Beitragvon PHabermehl » 10 Jul 2018, 14:44

FischRob hat geschrieben:Nachdem nun alles läuft habe ich mal mit Brickly angefangen.
Wie kann ich in Brickly speichern und Laden um an einem angefangenen Projekt weiterzuatbeiten?


Das passiert automatisch, das Projekt bleibt immer auf dem TXT gespeichert.

Um das Projekt vom TXT herunterzuladen, um es z.B. auf einen anderen TXT zu kopieren oder um es zu archivieren, kannst du die App "BrickMCP", das "Brickly Master Control Program" benutzen:
viewtopic.php?f=33&t=4018

Gruß
Peter
PHabermehl
 
Beiträge: 865
Registriert: 20 Dez 2014, 23:59
Wohnort: Bad Hersfeld
Alter: 45

Re: nach gelungener Installation keine Informationen mehr

Beitragvon FischRob » 11 Jul 2018, 16:40

Hallo,
ich kann in Brickly den Mülleimer nicht mehr aufmachen und keine ungenutzten Programmteile entfernen.
Das ging aber am Anfang.
Was kann ich tun?

Gruß
FischRob
FischRob
 
Beiträge: 54
Registriert: 01 Nov 2010, 10:51

Re: nach gelungener Installation keine Informationen mehr

Beitragvon PHabermehl » 11 Jul 2018, 16:44

Brickly-spezifisch sollte eigentlich im Brickly-Thread weiterdiskutiert werden:

viewtopic.php?f=33&t=3840

Spontan zwei Tips an dieser Stelle:
1) Hast Du mit BrickMCP das Projekt schreibgeschützt?
2) Hast Du den "Erfahrungslevel" heruntergesetzt?

Gruß
Peter
PHabermehl
 
Beiträge: 865
Registriert: 20 Dez 2014, 23:59
Wohnort: Bad Hersfeld
Alter: 45

Re: nach gelungener Installation keine Informationen mehr

Beitragvon FischRob » 11 Jul 2018, 17:57

Weder - noch.
Ich habe folgende Beobachtung gemacht. Ich kann auch jetzt wieder löschen - allerdings nur neue Elemente. Hier geht der Abfalleimer auf und das Programmteil ist weg. Bei übriggebliebenen Logic-Elementen funktioniert das allerdings nicht. Der Mülleimer bleibt zu. Ich habe auch versucht die Logic-Programmteile zu reaktivieren und jetzt zu löschen - geht auch nicht.
Bei einem neuen Programm funktioniert das Löschen wieder.
Eigenartiges Verhalten. Auch bei rechter Maustaste auf den Mülleimer und alles löschen bleibt immer noch ein Rest übrig.
FischRob
 
Beiträge: 54
Registriert: 01 Nov 2010, 10:51


Zurück zu TXT-Sonderprogrammierungen

Wer ist online?

Mitglieder in diesem Forum: FischRob und 2 Gäste