TX-Pi: Einfache Installation mit SD card image

Community-Firmware (cfw), Selbstbaucontroller (TX-Pi, ftduino, usw.), 3D-gedrucktes Zubehör, usw
Forumsregeln
Bitte beachte die Forumsregeln!

TX-Pi: Einfache Installation mit SD card image

Beitragvon PHabermehl » 08 Mär 2019, 12:29

Hallo Zusammen,

um die TX-Pi-Installation signifikant zu vereinfachen und zu beschleunigen, haben wir SD-Karten-Images für die Varianten mit 3.2" und 3.5"-A-Display bereitgestellt.

https://github.com/harbaum/tx-pi/blob/master/README.md#sd-card-images

Einfach analog zu einem Raspbian-Image gemäß der Raspbian-Anleitung installieren...

Viele Grüße
Peter
Moderative Beiträge sind explizit gekennzeichnet!
PHabermehl
Moderator
 
Beiträge: 1166
Registriert: 20 Dez 2014, 23:59
Wohnort: Bad Hersfeld
Alter: 46

Re: TX-Pi: Einfache Installation mit SD card image

Beitragvon tintenfisch » 08 Mär 2019, 20:20

PHabermehl hat geschrieben:um die TX-Pi-Installation signifikant zu vereinfachen und zu beschleunigen, haben wir SD-Karten-Images für die Varianten mit 3.2" und 3.5"-A-Display bereitgestellt.


Das ist super, das geht wirklich signifikant schneller. Einstecken und schwups ist ein TX-PI da. :)

Ein paar Anmerkungen:
  • Du hast in der confix.txt dtoverlay=waveshare35a:rotate=180, speed=40000000 stehen, was für mich super ist, weil der "speed" Parameter ignoriert wird, da das mit meinem Display (3.5" rev. 4) nicht funktioniert und ich nur verrückte Farben bekomme. War das so beabsichtigt? Sofern Deine Intention war, das SPI auf 40 MHz zu setzen, müßte das Leerzeichen weg. Ich wäre aber dafür, das ganz herauszulassen, weil das nicht bei jedem Display zu funktionieren scheint.
  • Ich habe eine "ssh" Datei in /boot/ gelegt sowie meine Netzwerkkonfiguration in der "wpa_supplicant.conf" abgelegt, aber das scheint ignoriert zu werden, der TX-PI loggt sich nicht ein. Ich habe es dann über die WLAN-App konfiguriert, aber der SSH-Server scheint nicht zu laufen (connection reset by ...).
  • Ich habe nun zwei Karten mit dem Image bespielt und jedes Mal war es so, das der TX-PI nach ein paar Minuten abstürzt oder ein Reboot durchgeführt wird. Läuft da irgendwas im Hintergrund, was einen Reboot erfordert? Nachdem der TX-PI einmal abgeschmiert ist, scheint er nach dem Neustart sauber durchzulaufen
  • Vielleicht wäre es noch schön, zu den Dateien noch die dazugehörigen Hash-Werte zu veröffentlichen, so dass man verifizieren kann, dass die Datei dem entspricht, was Du ursprünglich mal hochgeladen hast.
tintenfisch
 
Beiträge: 27
Registriert: 03 Jan 2018, 23:04

Re: TX-Pi: Einfache Installation mit SD card image

Beitragvon PHabermehl » 08 Mär 2019, 20:34

Hallo Lars,

danke für die Rückmeldung!

  • Oh, das mit der config.txt ist ein Fehler... Fliegt beim nächsten mal wieder ganz 'raus, ist aber nicht schädlich für den Moment...
  • Uh, oh, was soll ich sagen? Hatte ich nicht überprüft, aber passiert bei mir auch...
  • Die Abstürze sind bei mir bislang nicht aufgetreten. Evtl. hängt das mit dem resize der Partition auf SD-Karte zusammen?
  • Okay, das sollte ich tun. Mittelfristig möchte ich die images ohnehin woanders gehostet sehen...

Wenn Du zur Aufklärung der Mysterien beitragen kannst, wäre das schön.

Gruß
Peter
Moderative Beiträge sind explizit gekennzeichnet!
PHabermehl
Moderator
 
Beiträge: 1166
Registriert: 20 Dez 2014, 23:59
Wohnort: Bad Hersfeld
Alter: 46

Re: TX-Pi: Einfache Installation mit SD card image

Beitragvon tintenfisch » 09 Mär 2019, 00:21

PHabermehl hat geschrieben:[...]
[*] Die Abstürze sind bei mir bislang nicht aufgetreten. Evtl. hängt das mit dem resize der Partition auf SD-Karte zusammen?


Ich habe in das PiShrink Script geguckt; es wird tatsächlich die Partition vergrößert und dann ein Reboot durchgeführt. Ich hatte das Image auf jeweils 32 GB Karten kopiert, dann käme das mit dem Zeitintervall wohl auch hin.
tintenfisch
 
Beiträge: 27
Registriert: 03 Jan 2018, 23:04

Re: TX-Pi: Einfache Installation mit SD card image

Beitragvon PHabermehl » 09 Mär 2019, 00:25

Ja, den Reboot nach resize kann ich inzwischen bestätigen. Hab eine 8GB Karte, das ist mir beim ersten Mal nicht aufgefallen, weil ich nicht ständig auf das Gerät geschaut habe!
Moderative Beiträge sind explizit gekennzeichnet!
PHabermehl
Moderator
 
Beiträge: 1166
Registriert: 20 Dez 2014, 23:59
Wohnort: Bad Hersfeld
Alter: 46

Re: TX-Pi: Einfache Installation mit SD card image

Beitragvon PHabermehl » 15 Mär 2019, 00:47

Hallo Zusammen,

dank tintenfisch - Lars - wurden ein paar Bugs in den image-files behoben. Netzwerk-, WLAN- und SSH-Zugriff sollten jetzt problemlos laufen. Die neuen Image-Dateien (Datum 2019-03-14) findet ihr auf GitHub im TX-Pi-Repository.

https://github.com/harbaum/tx-pi/blob/master/README.md#sd-card-images

Gruß
Peter
Moderative Beiträge sind explizit gekennzeichnet!
PHabermehl
Moderator
 
Beiträge: 1166
Registriert: 20 Dez 2014, 23:59
Wohnort: Bad Hersfeld
Alter: 46

Re: TX-Pi: Einfache Installation mit SD card image

Beitragvon PHabermehl » 18 Mär 2019, 22:47

So, korrigierte Images unter dem obigen Link auf GitHub bereitgestellt.

Gruß Peter
Moderative Beiträge sind explizit gekennzeichnet!
PHabermehl
Moderator
 
Beiträge: 1166
Registriert: 20 Dez 2014, 23:59
Wohnort: Bad Hersfeld
Alter: 46


Zurück zu Community-Projekte

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste