Probleme mit der Z-Achse des Druckers

Hier habt Ihr die Möglichkeit direkt mit dem fischertechnik Team in Kontakt zu treten
Here you have the Possibility to get in direct contact with the fischertechnik-Team

Moderator: fischertechnik Mitarbeiter

Forumsregeln
Bitte beachte die Forumsregeln!

In dieser Unterkategorie können nur fischertechnik-Mitarbeiter und Moderatoren antworten!
canu
Beiträge: 39
Registriert: 23 Dez 2012, 10:24

Probleme mit der Z-Achse des Druckers

Beitrag von canu » 18 Aug 2016, 11:28

Hallo ft-Support,

der neue Drucker gefällt mir grundsätzlich sehr gut. Leider gelingt es mir nicht die Z-Achse so aufzubauen, dass der Drucker korrekt funktioniert. Der Drucker bewegt sich bei den folgenden Layern nicht ausreichend nach oben, so dass der Druckkopf die bereits gedruckten Ebenen berührt und verschmiert. Tests mit der Handsteuerung ergaben, dass der Druckkopf im unteren Bereich keine 0,1 Schritt nach oben ausführt. Größere Schritte funktionieren problemlos. Nach einigen 1er Schritten sind 0,1 Schritte möglich. Bis auf die Probleme im unteren Bereich scheint die Achse problemlos zu laufen. Da ich die beiden Z-Achsen bereits dreimal auseinandergebaut, geprüft und geschmiert habe, wäre ich sehr dankbar für Tipps bzw. Hilfe.
In der Bauanleitung der Kette sind 138 Einzelteile angegeben. Mit dieser Anzahl liegt sie jedoch bei mir viel zu locker an, so dass ich einige Kettenglieder entfernt habe. Ist das OK?
Außerdem fand ich das Bauen mit den Alus sehr schwierig, da sie sehr schwergängig sind. Hätte man zum Einschieben etwas Silikonfett nehmen dürfen?

Grüße canu

Benutzeravatar
thomasdr
Beiträge: 135
Registriert: 02 Nov 2010, 17:00
Kontaktdaten:

Re: Probleme mit der Z-Achse des Druckers

Beitrag von thomasdr » 18 Aug 2016, 19:39

Hallo,
ich möchte eine Vermutung äußern.
Der Stepper der z-Achse bekommt nicht genug oder zu viel Strom.
Den Stepperstrom kann man bei diesem Treibertyp normalerweise mit einem kleinem Trimmer (Poti) einstellen.
Auf dem Controller sieht man auch neben jedem Treiber IC einen Trimmer. Man könnte den Trimmer geringfügig verändern. Bitte nur wenig ändern da die Stromänderung sonst zu stark ausfällt.
Bekommt der Stepper zu wenige Strom bewegt er sich nicht oder verliert Schritte. Wenn er schon in Bewegung ist braucht er weniger Strom. Das würde zu deiner Beschreibung passen. Bei zu hoher Stromstärke überhitzen Treiber und Motor und auch dann kann der Motor stottern.
Messen kann man das ganze nur etwas umständlich. Ein Amperemeter in die Stromversorgung. Den Ruhestrom feststellen. Dann den gewünschten Motor/Achse in Repetier Host aktivieren.

Anbei gängige Werte für diese Treiber und Drucker im Prusa I3 Format, die dieser Konstruktion entsprechen.

Steuerung Stromstärke (mA)
X-Achse 250
Y-Achse 250
Z-Achse 450

Der ft Drucker kann natürlich davon abweichen. Die Motoren und damit die Ströme fallen vermutlich eine Nummer kleiner aus.
Dann mich bitte korrigieren. Vielleicht steht auch was in den Unterlagen.

Am besten das erst von fischertechnik bestätigen lassen.

Gruß Thomas

Benutzeravatar
MasterOfGizmo
Beiträge: 1804
Registriert: 30 Nov 2014, 07:44

Re: Probleme mit der Z-Achse des Druckers

Beitrag von MasterOfGizmo » 18 Aug 2016, 21:00

Da anzunehmen ist, dass die Teile von FT bereits aufeinander abgestimmt sind, halte ich es für wenig zielführend, gleich an den Grundeinstellungen des Controllers zu drehen.

Wenn der Motor tatsächlich mehr Strom benötigt, dann würde ich die Ursache erstmal in einer schwergängigen Mechanik suchen. Ggf laufen die Schnecken nicht ganz parallel oder ähnlich. An den Potis rumdrehen solltest Du m.E. erst auf Anraten von FT selbst.

Edit: Dreht sich denn der Motor auch im unteren Bereich ein Stück, wenn Du 0,1 mm fährst? Falls ja ist der Motorstrom eh nicht das Problem.
ftDuino, der Arduino für fischertechnik: http://ftduino.de

Benutzeravatar
H.A.R.R.Y.
Beiträge: 852
Registriert: 01 Okt 2012, 08:38
Wohnort: Westpfalz

Re: Probleme mit der Z-Achse des Druckers

Beitrag von H.A.R.R.Y. » 19 Aug 2016, 07:04

canu hat geschrieben: In der Bauanleitung der Kette sind 138 Einzelteile angegeben. Mit dieser Anzahl liegt sie jedoch bei mir viel zu locker an, so dass ich einige Kettenglieder entfernt habe. Ist das OK?
Hallo canu,

hast Du die Gegenprobe schon gemacht?

Wenn die Kette zu stramm sitzt, reicht eventuell das Drehmoment vom Motor nicht aus die dann schwergängige Mechanik zu bewegen und er verliert Schritte.

Also steck in Deiner gekürzten Kette mal ein Kettenglied dazu und teste es erneut aus.

Grüße
H.A.R.R.Y.
(auch *kein* fischertechnik-MA)
[42] SURVIVE - or die trying

Markus Burkhardt
Beiträge: 171
Registriert: 12 Jan 2016, 09:13

Re: Probleme mit der Z-Achse des Druckers

Beitrag von Markus Burkhardt » 19 Aug 2016, 09:53

Hallo canu,

es tut uns sehr leid, dass es zu einem Problem bei deinem 3D-Drucker kam. Der von dir beschriebene Fehler ist uns neu, ich aber trotzdem guter Dinge, dass wir wir ihn beheben können. Für den Anfang wäre es prima, wenn du mir ein Foto deines aufgebauten Druckers (gerne auch mehrere) schicken könntest. Außerdem wäre es toll, wenn du den Motor MZ mit dem Motor MY tauschen könntest. Das würde uns Aufschluss darüber geben, ob der Motor die Ursache ist oder nicht.

Viele Grüße
Markus
(ft-Mitarbeiter)

canu
Beiträge: 39
Registriert: 23 Dez 2012, 10:24

Re: Probleme mit der Z-Achse des Druckers

Beitrag von canu » 20 Aug 2016, 09:27

Hallo zusammen,

vielen Dank für die Hinweise.

@H.A.R.R.Y. ... Gegenprobe mit einem Kettenglied mehr habe ich gemacht. Kette war sehr schlabbrig und lief definitiv schlechter als mit den verbauten 136 Kettengliedern.

@thomasdr ... interessant - jedoch möchte ich aus verständlichen Gründen so etwas erst als letzte Option ausprobieren.

@Markus Burkhardt
Ich werde am Wochenende die Fotos machen und den Motor tauschen. Soll ich die Bilder auf der Communityseite hochladen, einen Link auf eine andere Seite mit den Bildern hier reinstellen oder die Bilder als eMail-Anhang senden (an info@fischertechnik.de?)?

Grüße
canu

HansWw
Beiträge: 16
Registriert: 15 Dez 2014, 22:08

Re: Probleme mit der Z-Achse des Druckers

Beitrag von HansWw » 21 Aug 2016, 12:42

Hallo zusammen,

Ich habe das gleiche Problem: der Drucker bewegt sich bei den folgenden Layern nicht ausreichend nach oben, so dass der Druckkopf die bereits gedruckten Ebenen berührt und verschmiert.
Ich habe mehrere Objekte gedruckt und das gleiche Problem tritt bei allen auf.
Zum Beispiel bei das 'angular_block-45-degrees' sind die Größen in X und Y-Richtung korrekt aber in Z-Richtung nur 12,8 mm wo ich 15 mm erwartet.

Allerdings ist das Material zugeführt und ist in der X- und Y-Richtung verdrängt.

Fotos sehen Sie hier:

http://www.wijnsouw.nl/fischertechnik/ftc/3d-printer/


Gruß Hans

Benutzeravatar
thomasdr
Beiträge: 135
Registriert: 02 Nov 2010, 17:00
Kontaktdaten:

Re: Probleme mit der Z-Achse des Druckers

Beitrag von thomasdr » 21 Aug 2016, 17:34

Hallo,

welches Steuerprogramm liegt dem Drucker bei? Repetier Host?
Ihr könntet damit den Druckkopf manuell eine gewisse Strecke nach oben fahren und die zurückgelegte Distanz am Drucker nachmessen.
Die sollte auf jeden Fall übereinstimmen.
Spürt man bei Drehen von Hand in dem Bereich 12..15 mm einen größeren Widerstand oder ein Ruckeln?
Wenn die Mechanik sauber läuft, bleibt eigentlich nur der Stepper.
Ist die Frage ob vor Auslieferung der Stepperstrom genau eingestellt wird. Bei einem 2500€ Ultimaker muss man das sicher nicht. Bei den Bausätzen dagegen ist es üblich das man es selber nachjustiert. Das geht notfalls auch ohne Messung. Wenn man Schritte verliert, verdreht man den Trimmer der jeweiligen Achse um wenige Grad und schaut ob es besser wird. In der Regel erhöht sich bei Rechtsdrehung die Referenzspannung für den Motorstrom. Es gibt aber Ausnahmen. Keine Ahnung wie das verwendete Printrboard verdrahtet wurde.
Die IC haben Thermo- und Überstromschutz und gehen nicht gleich kaputt. Wenn es nicht hilft, auf alte Einstellung zurück. (Vorher Foto?)
Mit Veränderung des Motorstromes kann sich auch das Betriebsgeräusch des Schrittmotors ändern.
Wäre natürlich keine Lösung für Kids...
Der Rest vom Aussehen geht wohl auf die Filamentkühlung.

Gruß Thomas

canu
Beiträge: 39
Registriert: 23 Dez 2012, 10:24

Re: Probleme mit der Z-Achse des Druckers

Beitrag von canu » 21 Aug 2016, 18:14

Hallo,

leider hat das Tauschen der Motoren bei mir nichts gebracht.
Also habe ich auch ein paar Bilder gemacht. Ich habe die Auflösung hoch gelassen, damit Details erkennbar bleiben.
Hier sind die Fotos zu finden:
http://ueruem.de/3D-Drucker/bild_1.jpg
http://ueruem.de/3D-Drucker/bild_2.jpg
http://ueruem.de/3D-Drucker/bild_3.jpg
http://ueruem.de/3D-Drucker/bild_4.jpg
http://ueruem.de/3D-Drucker/bild_1.jpg
http://ueruem.de/3D-Drucker/bild_6.jpg
http://ueruem.de/3D-Drucker/bild_7.jpg

@thomasdr
Wenn die Z-Achse in der Homestellung ist, reagiert der Drucker nicht auf die Ansteuerung mit 0,1er Schritten. In der Steuersoftware wird die Position jedoch entsprechend der Eingaben erhöht.

Grüße Can

Benutzeravatar
thomasdr
Beiträge: 135
Registriert: 02 Nov 2010, 17:00
Kontaktdaten:

Re: Probleme mit der Z-Achse des Druckers

Beitrag von thomasdr » 21 Aug 2016, 19:14

Hallo Can,

die z-Achse hat bei dieser Konstruktion einiges an Reibungsverlusten.

An Hand der Fotos ist der Stepper wohl ein 14HS5405. Den Typ finde ich nicht. An Hand der Bezeichnung der übrigen Moons Motoren könnte es ein 0,5 A Typ sein. Die Angabe der Nm wäre auch interessant.

Viele Drucker sparen sich den gemeinsamen Antrieb beider Z-Gewinde und verwenden 2 Stepper und schalten diese einfach parallel. Mein Prusa hat zwei 2,6A Stepper bei weniger Reibung, allerdings müssen diese mehr Gewicht heben. Sie teilen sich 650 mA Stepperstrom.

Das Problem verstehe ich trotzdem nicht, da ich davon ausgehe, dass man vorher ausgiebig getestet hat.
Vielleicht ist in der Serie ein anderes Bauteil oder eine andere Einstellung.

Sofern die Mechanik ok ist, wäre für mich immer noch der Stepperstrom der Favorit.
Das würde ich gern abwarten. Dann kann man sich Gedanken über einen konstruktiven Eingriff machen.

Gruß Thomas

Markus Burkhardt
Beiträge: 171
Registriert: 12 Jan 2016, 09:13

Re: Probleme mit der Z-Achse des Druckers

Beitrag von Markus Burkhardt » 22 Aug 2016, 09:13

Hallo Can,

vielen Dank für die Bilder. Wenn sich durch den Tausch der Motoren nichts geändert hat, würde ich den Motor als Fehlerquelle ausschließen. Auf deinen Bildern ist auch kein Baufehler zu erkennen.

Was passiert denn, wenn du die Kette wegmachst und dann den Motor ansteuerst? Dreht sich der Motor dann?

Viele Grüße
Markus

HansWw
Beiträge: 16
Registriert: 15 Dez 2014, 22:08

Re: Probleme mit der Z-Achse des Druckers

Beitrag von HansWw » 23 Aug 2016, 22:11

Hallo,

Ein Update von mein Z-Achse-Problem.
Ich habe die komplette Z-Achsen ausgebaut und geprüft auf Leichtgängigkeit und wieder mit etwas Fett geschmiert.
Die Achsen laufen so leicht wie möglich.
Aber ich habe noch immer das problem.
Wenn die Z-Achse 5 x 0,1 mm nach oben geht, braucht es nur 4 x 0,1 mm nach unten um an der gleichen Stelle zu kommen.
Ich glaube nicht, dass es ein mechanisches Problem ist.
Kan es ein elektrisches Problem oder ein Software-Problem sein?

Gruß Hans

Benutzeravatar
MasterOfGizmo
Beiträge: 1804
Registriert: 30 Nov 2014, 07:44

Re: Probleme mit der Z-Achse des Druckers

Beitrag von MasterOfGizmo » 24 Aug 2016, 10:37

elektrolutz hat geschrieben: Edit: Für diesen 3D-Drucker wäre eine Kooperation z.B. mit der Fa. igus sicherlich nicht verkehrt gewesen.
Zitat von:
http://www.fischer.de/de-DE/Unternehmen ... hertechnik

"in Zusammenarbeit mit dem 3D-Druck-Spezialisten German RepRap GmbH bei fischertechnik entwickelt "
ftDuino, der Arduino für fischertechnik: http://ftduino.de

mario
Beiträge: 3
Registriert: 17 Aug 2016, 19:24

Re: Probleme mit der Z-Achse des Druckers

Beitrag von mario » 24 Aug 2016, 17:29

Hello ft fans

Why fischertechnik does not react on the above described problem(s). Meanwhile one accusation after another appear on the screen. That will (probably) bring the 3D printer in discredit.

kind ragrds
Rien van Harmelen

Benutzeravatar
MasterOfGizmo
Beiträge: 1804
Registriert: 30 Nov 2014, 07:44

Re: Probleme mit der Z-Achse des Druckers

Beitrag von MasterOfGizmo » 24 Aug 2016, 21:09

mario hat geschrieben: Why fischertechnik does not react on the above described problem(s). Meanwhile one accusation after another appear on the screen. That will (probably) bring the 3D printer in discredit.
They replied twice making suggestions what to check and how. The second time they did not receive an answer so the dialogue stopped there. You cannot blame FT for that. Nevertheless I am sure they still look into these issues.

And some of the loudest and most demanding voices here don't even own a 3d printer and just repeat hearsay. There's not much to discuss with them as they don't seriously want to be answered,

Really, this is a recently released bleeding edge construction kit. Given the fact that some here claimed the printer wouldn't work at all before it was even released I'd just give FT and the rest of the community some more time to identify and address the most common problems. Actually the Z axis seems to the the only issue so far that more than 1 person experienced. I am sure it can be fixed. It's only a mechanical issue which FT can fix without having to rely on their suppliers :-)

I can't wait for my printer to arrive ....
ftDuino, der Arduino für fischertechnik: http://ftduino.de

Benutzeravatar
MasterOfGizmo
Beiträge: 1804
Registriert: 30 Nov 2014, 07:44

Re: Probleme mit der Z-Achse des Druckers

Beitrag von MasterOfGizmo » 24 Aug 2016, 21:16

Btw: Someone mentioned he has added ball bearings to his z axis. I'd really like to see pictures of that.
ftDuino, der Arduino für fischertechnik: http://ftduino.de

Benutzeravatar
MasterOfGizmo
Beiträge: 1804
Registriert: 30 Nov 2014, 07:44

Re: Probleme mit der Z-Achse des Druckers

Beitrag von MasterOfGizmo » 24 Aug 2016, 21:32

HansWw hat geschrieben: Die Achsen laufen so leicht wie möglich.
Aber ich habe noch immer das problem.
Wenn die Z-Achse 5 x 0,1 mm nach oben geht, braucht es nur 4 x 0,1 mm nach unten um an der gleichen Stelle zu kommen.
Ich glaube nicht, dass es ein mechanisches Problem ist.
Kan es ein elektrisches Problem oder ein Software-Problem sein?
Du kannst noch ein paar Dinge probieren:
  • Entferne die Kette und lasse den Motor frei drehen. 5 * 0.1 in die eine Richtung, dann 5 * 0.1 in die andere Richtung. Hast Du auch dann das Problem, dass er nicht wieder in der Ausgangposition ankommt?
  • Mit Kette montiert schau genau auf das Zahnrad am Z-Motor. Ein Schrittmotor heisst so, weil er nur ganze Schtitte fährt. Siehst Du bei dem 5 runter / 4 rauf-Problem, dass der Motor einen Schritt auslässt? Ich mache für sowas gerne Marker auf Zahnräder direkt am Motor. Dann kann man git sehen, wie weit er sich bewegt hat.
  • Ohne Kette kannst Du den Motor mit den Fingen etwas festhalten und dann laufen lassen. Lässt er sich leicht bremsen? Schrittmotoren dieser Größe sollten eingenlich recht kraftvoll sein und sich nicht so leicht manuell bremsen lassen
ftDuino, der Arduino für fischertechnik: http://ftduino.de

Benutzeravatar
Defiant
Beiträge: 330
Registriert: 31 Okt 2010, 21:42
Wohnort: Narn Homeworld
Kontaktdaten:

Re: Probleme mit der Z-Achse des Druckers

Beitrag von Defiant » 24 Aug 2016, 22:13

Bei mir war die Z-Achse auch Schwergängig und ich konnte sie nicht in 0.1mm Schritten bewegen: Eine Drehung der Zahnräder in eine Richtung in kleinen Schritten wurde mit einer Drehung in die entgegengesetzte Richtung beantwortet. Ursache war, dass die beiden jeweiligen Schneckenmuttern nicht um 90° gedreht montiert wurden.

Ein weiteres Problem hieraus ist übrigens, dass beide Motorkupplungen (mit Zahnrad und ohne) übrigens zu schwach für die Schrittmotoren sind. Ist der Widerstand zu hoch drehen die Schrittmotoren größere Schrittweiten trotzdem. Nach einiger Zeit drehen die Motorachsen dann in den Kupplungen durch und die Kupplung ist hin.

Markus Burkhardt
Beiträge: 171
Registriert: 12 Jan 2016, 09:13

Re: Probleme mit der Z-Achse des Druckers

Beitrag von Markus Burkhardt » 25 Aug 2016, 09:19

Hallo zusammen,

vielen Dank für die vielen Anmerkungen und Erfahrungsberichte. Ein Umkehrspiel in der z-Achse stört beim Drucken nicht, da sich die z-Achse monoton nach oben bewegt. Die beiden anderen Achsen haben, sofern der Drucker korrekt aufgebaut wurde, sehr sehr wenig Umkehrspiel.

Die Anmerkung von Defiant, dass eventuell die Schneckenmuttern falsch eingebaut sind, könnte Canus Problem verursachen. Leider ist dies auf den Bildern nicht erkenntlich.

@Defiant: Benötigst du neue Kupplungen?

Viele Grüße
Markus

Benutzeravatar
MasterOfGizmo
Beiträge: 1804
Registriert: 30 Nov 2014, 07:44

Re: Probleme mit der Z-Achse des Druckers

Beitrag von MasterOfGizmo » 25 Aug 2016, 12:18

Markus Burkhardt hat geschrieben:Ein Umkehrspiel in der z-Achse stört beim Drucken nicht, da sich die z-Achse monoton nach oben bewegt.
Würde das nicht bei der allerersten Lage stören? Da kommt die Z-Achse ja erst einmal von oben gefahren. Wenn dann Umkehrspiel vorhanden ist würde der Druckkopf nach dem Drucken der ersten Lage nicht weit genug angehoben.
ftDuino, der Arduino für fischertechnik: http://ftduino.de

Gesperrt